A molti è capitato di imbattersi su come sviluppare automatismi per realizzare un qualsiasi backup della configurazione di rete su Mikrotik base.

Questo script è l'ideale per ogni fabbisogno ed esporta sia il radius manager che l'export della configurazione globale, non funziona con email in SSL per il momento.

/file remove $logbackup
/file remove $umbackup
/file remove $mikrotikexport
/file remove $backupfile

:log info "Cancellazione del backup dalla routerboard. OK!"
:log info "Fine backup":delay 20s
:log info "Fine invio email"


:log info "Mikrotik Backup Radius Totale"  (stampa LOG)
:global backupfile configbackup               (backup sistema)
:global mikrotikexport mtexport_backup   (esportazione script .rsc)
:global umbackup um_backup                 (backup del DB UM)
:global logbackup log_backup                  (backup del log UM)
:global email xxxxx(AT)xxxxx.it              (ovviamente ci va la mail reale)
:global port 25                                       (porta SMTP autenticazione)
:global password yyyyy                            (la password reale)
:global smtp 0.0.0.0                               (l'IP del server di posta)
:global sendto yyyyy(AT)yyyyy.it               (la mail di destinazione)

:log info "Cancellazione del vecchi backup se disponibili, altrimenti passa ad elaborazione successiva . . . "

/system backup save name=$backupfile
/export file=$mikrotikexport

/tool user-manager database save name=$umbackup
/tool user-manager database save-logs name=$logbackup


:log info "Processo di backup con pausa di 20 secondi in modo da completare la creazione di file di backup"
:delay 20s
:log info "Invio dei backup via Email usando SMTP statico. . ."

/tool e-mail set address=$smtp from=$email password=$email port=$port starttls=no user=$email

:log info "Set di 10 secondi tra la connessione al server ed invio della prima mail"
:delay 10s
/tool e-mail send to=$sendto subject=([/system clock get date] . " Radius Config Backup") from=$email file=$backupfile server=$smtp tls=no

:log info "Set di 10 secondi tra la mail (Radius Config Backup) e (Radius Export Backup)"
:delay 10s

/tool e-mail send to=$sendto subject=([/system clock get date] . " Radius Export Backup") from=$email file=$mikrotikexport server=$smtp tls=no

:log info "Set di 10 secondi tra la mail (Radius Export Backup) e (Radius User Manager Backup)"
:delay 10s
/tool e-mail send to=$sendto subject=([/system clock get date] . " Radius User Manager Backup") from=$email file=$umbackup server=$smtp tls=no

:log info "Fine invio email"

:log info "Set di 10 secondi tra la mail (Radius Export Backup) e (Radius User Manager LOG Backup)"
:delay 10s

/tool e-mail send to=$sendto subject=([/system clock get date] . " Radius User Manager LOG Backup") from=$email file=$logbackup server=$smtp tls=no

:log info "Fine invio email"

:delay 20s
:log info "Fine backup"
:log info "Cancellazione del backup dalla routerboard. OK!"
/file remove $backupfile
/file remove $mikrotikexport
/file remove $umbackup
/file remove $logbackup

Tra poco su questo SITO.

Ti invito nel frattempo a visitare il sito www.informaticaezzelina.it